An open source implementation of the Ultima Online Classic Client.

Windows x64 Linux x64 macOS

Requirements

  • OS [x64 only]: Windows 7 and newer, Linux glibc 2.17+, macOS 10.9 Mavericks or newer
  • Graphics: DirectX 11, Metal, OpenGL 3.0+ support (2.1 with ARB extensions acceptable), Vulkan